build: Updating dependencies

composer:
* mediawiki/mediawiki-codesniffer: 34.0.0 → 35.0.0
* mediawiki/minus-x: 1.1.0 → 1.1.1

npm:
* eslint-config-wikimedia: 0.17.0 → 0.18.1

Additional changes:
* Added the "composer phan" command to conveniently run phan.
* Removing manual extensions for eslint.

Change-Id: I9579b8c532cb211834783324995a5e115b844d00
This commit is contained in:
libraryupgrader 2021-01-30 07:04:05 +00:00
parent 4106112303
commit 4d1d8ad72f
4 changed files with 693 additions and 402 deletions

View File

@ -15,7 +15,6 @@ module.exports = function ( grunt ) {
banana: conf.MessagesDirs,
eslint: {
options: {
extensions: [ '.js', '.json' ],
cache: true
},
all: [

View File

@ -1,8 +1,8 @@
{
"require-dev": {
"mediawiki/mediawiki-codesniffer": "34.0.0",
"mediawiki/mediawiki-codesniffer": "35.0.0",
"mediawiki/mediawiki-phan-config": "0.10.6",
"mediawiki/minus-x": "1.1.0",
"mediawiki/minus-x": "1.1.1",
"php-parallel-lint/php-console-highlighter": "0.5.0",
"php-parallel-lint/php-parallel-lint": "1.2.0"
},
@ -15,6 +15,7 @@
"parallel-lint . --exclude node_modules --exclude vendor",
"phpcs -p -s",
"minus-x check ."
]
],
"phan": "phan -d . --long-progress-bar"
}
}

1085
package-lock.json generated

File diff suppressed because it is too large Load Diff

View File

@ -7,7 +7,7 @@
"test": "grunt test"
},
"devDependencies": {
"eslint-config-wikimedia": "0.17.0",
"eslint-config-wikimedia": "0.18.1",
"grunt": "1.3.0",
"grunt-banana-checker": "0.9.0",
"grunt-eslint": "23.0.0"