mediawiki-extensions-Interw.../composer.json
libraryupgrader 098426994d build: Updating composer dependencies
* mediawiki/minus-x: 1.1.1 → 1.1.3
* php-parallel-lint/php-parallel-lint: 1.3.2 → 1.4.0

Change-Id: I019d1278e0132db6a4f58d0c86678f41c0c754b4
2024-05-05 21:00:25 +00:00

26 lines
519 B
JSON

{
"require-dev": {
"mediawiki/mediawiki-codesniffer": "43.0.0",
"mediawiki/minus-x": "1.1.3",
"php-parallel-lint/php-console-highlighter": "1.0.0",
"php-parallel-lint/php-parallel-lint": "1.4.0"
},
"scripts": {
"test": [
"parallel-lint . --exclude vendor --exclude node_modules",
"@phpcs",
"minus-x check ."
],
"fix": [
"minus-x fix .",
"phpcbf"
],
"phpcs": "phpcs -sp --cache"
},
"config": {
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
}
}
}